Inhalt

Navigation: »No topics above this level«

Inhalt

 Return to chapter overview

Das Programm liest aus einer Adis-Datei die Struktur aus und erzeugt damit für jede Entität eine Datenbank.

Anschließend werden die einzelnen Zeilen in die entsprechende Datenbank eingelesen.

Damit die Spaltenüberschriften und der Typ (Zeichen,Zahlen,DezimalZahlen ,Datum, Zeit) sowie Codeset lesbar sind,

kann der Benutzer in einer gesonderten Datenbank dies einpflegen. Alle Änderungen in der Datenbank haben

keinen Einfluß auf die Original Adis-Datei.

Es ist aber wohl möglich die Änderungen in eine andere Adis-Datei abzuspeichern.


Über Adis-Dateibetrachter

Navigation: Inhalt >

Über Adis-Dateibetrachter

Der Adis-Dateibetrachter kann nicht nur Adisdateien betrachten, sondern es ist auch ein Ändern der Daten möglich.

Das Programm hat folgende Vorzüge:

- Anzeige der Spalten-Überschriften im Klartext (also keine 6 stellige Zahl)

- für jede einzelne Entität, für die ein Codeset existiert, kann dieses auch angezeigt werden

- genaue Anzeige der Adis-Struktur

- jeder einzelne Wert einer Entität kann geändert werden

- es besteht eine detalierte Suchmöglickeit innerhalb der Tabelle

- für jede Spalte kann ein Suchfilter gelegt werden die auch mehrere Spalten umfasst

- jede Spalte kann sortiert werden (aufsteigend oder absteigend)

- Multisortierung ist möglich (also mehrere Spalten können in die Sortierung aufgenommen werden)

- jede Spalte innerhalb der Tabelle kann verschoben werden oder per Drag & Drop aus der Tabelle genommen werden

- Gruppierungen sind für jede Tabellenspalte möglich

- Entitäten mit Kommastellen werden sofort als numerische Spalten mit Durchschnitt (AVG) angezeigt

- Datum- bzw Datum-Zeitwerte Entitäten können durch den Nutzer als solches auch angezeigt werden

- Entitäten die Zahlen enthalten können auch als solche konvertiert werden

- Werte der Spalten können filterbezogen geändert werden

- Export der ganzen Tabelle bzw. bestimmte Zeilen zu Excel

- Export in Text-Datei bzw. html,csv oder xml


Start

Start

Nach dem 1. Start des Programmes können Sie folgendes sehen:

Das Programm braucht beim ersten Start die Angabe des Pfades zur Database. Diese Angabe wird

dann in der Datei "OptionAdis.ini" gespeichert.Speicherort dieser Datei ist immer das Direktorie dieses

Programmes.Die Database ist im Unterordner "Daten" gespeichert.

Nach dem Öffnen einer Adis-Datei sehen Sie folgendes:

Die Schalter (Buttons) haben folgende Bedeutung:

Adis Datei öffnen

Letzte Adis-Datei öffnen

Adisstruktur Zeigt in einem neuen Fenster die Struktur der Adis-Datei

Itemsbearbeiten Zeigt in einem neuen Fenster eine Tabelle zur Konfiguration der Tabellen der Adisdatei

Tabellen Navigator

von links nach rechts haben die Symbole folgende Bedeutung:

-DatenNavigation

-Einfügen, löschen und bearbeiten

- sichern oder abbrechen von Änderungen

- sichen oder springen zu einem Vermerk

- Erstellen von Filterbeziehungen und deren Verwendung

Adis abspeichern hier können Sie die gesamte Adisdatei oder Änderung neu abspeichern

Spaltenmanager hiermit verwalten Sie die einzelnen Spalten und Bereiche der aktuellen Tabelle

Exit

Spaltenwerte ändern hier können Sie alle oder selektierte Werte einer Spalte mit einem Click ändern

Tabelle abspeichen als abspeichern der aktuellen Tabelle als (Excel, Text,csv, Html oder Xml-Datei

Tabelle Ausdruck der von Ihnen designten aktuellen Tabelle (Rechte)

Struktur Ausdruck der Strukturtabelle (Linke)

Eigenschaften der Tabelle Ändern von Spaltennamen ,Typ ,Codeset

Gruppieren gleiche Werte der betreffenden Spalte werden zusammengefasst.


Adis-Datei öffnen

Adis-Datei öffnen

Im folgenden soll auf die Arbeit mit dem Betrachter eingegangen werden.

Es gibt in diesem Programm zwei Wege um eine Adis-Datei zu öffnen

1. Über "AdisDatei öffnen"

2. Über "Letzte Adis-Datei öffnen"

Zu Pkt1. Nach dem Öffnen der Adis-Datei wird die Adis-Struktur in einer Tabelle gespeichert und für jede

Entität eine gesonderte Tabelle erstellt.

Die Aktivitäten sind in der Progressbar weiter unten zu sehen. Je nach Anzahl der Entitäten kann

dies einen Moment dauern. Das Programm ist erst dann bereit wenn rechts die Header-Tabelle angezeigt wird!

Alle Änderungen in den Tabellen dieses Programmes haben keine Auswirkungen auf die Original Adis-Datei.

Gefährlich wird es nur, wenn Sie mit "Adis abspeichern" dasselbe Verzeichnis und den gleichen Dateinamen Ihrer Original-

datei verwenden!!

Zu Pkt2. Es wird die bestehende Adis-Datei (z.B nach dem Beenden des Programmes ) wieder geöffnet.

Nach dem Öffnen der Adis-Datei wird immer der "Header" angezeigt.

In der linken Tabelle wird die Adis-Struktur der Adis-Datei angezeigt. Mit einem Click auf das + Zeichen kann die ganze Struktur der

Tabelle gesehen werden.Mit einem Click auf den Knoten können andere Entitäten in Tabellen-Form geöffnet werden.

Durch den Pink-farbenen Splitter haben Sie die Möglichkeit die Breite der Adis-Struktur-Tabelle zu verbreitern bzw. zu verkleinern.

In der rechten Tabelle wird die Entitätstabelle dargestellt. Ein Item wird als eine Spalte der Tabelle dargestellt.


Hinzufügen / Löschen / Ändern

Hinzufügen / Löschen / Ändern

Mit Hilfe des Tabellen-Navigators können Sie in der aktuellen Tabelle Sätze einfügen,löschen oder auch ändern.

Wenn sie das Minuszeichen des Tabellen Navigators drücken wird dieser Satz ohne Nachfrage gelöscht. Dies hat jedoch keine Auswirkungen auf die Original geladene Adis-Datei!

Sie sollten jedoch wissen was Sie tun!!!


Tabellenkopf und Spalten

Tabellenkopf und Spalten

Im Tabellenkopf werden die Spalten(Items) einer Entität der Adisdatei dargestellt. Zuerst wird die 6-Stellige ItemNr und anschließend

der Name (Itembezeichnung) dargestellt. Besteht die Bezeichnung aus mehreren Worten, so werden diese bei Verkleinerung der Spaltenbreite zur besseren Lesbarkeit untereinander aufgelistet.

Der Name der Itemnummer wird in einer gesonderten Datei geführt. Dabei kann die Bezeichnung ganz nach Ihren Bedürfnissen angepaßt werden. Diese ereichen Sie im Menü mit "Items bearbeiten" . Ist im Spaltenkopf nur die ItemNr. zu sehen, dann ist diese ItemNr.

noch nicht in der Datei augeführt. Die Eigenschaften der einzelnen Spalten werden in einer gesonderten Datei geführt.

Änderungen daran werden in der Tabelle nur nach erneutem Auruf der Adis-Datei wirksam.


Bänder der Tabelle

Bänder der Tabelle

Die Bänder "Fest" und "Variabel" (auch Bereiche genannt), hier in blau, dienen der besseren Lesbarkeit der Tabelle.

Das Band "Fest" ist fest links in der Tabelle fixiert. Beim Scrollen der Tabelle nach links bleiben die Spalten hier fixiert.

Spalten können beliebig in diese Bereiche verschoben werden, indem man sie mit der linken Maustaste am Spaltenkopf dort hin verschiebt.

Hier kann man die Bänder ein oder ausblenden

Das Band "Variabel" kann auch komplett in den Spaltenmanager verschoben werden indem man mit der linken Maustaste auf das Band klickt und dann in den geöffneten Spaltenmanager zieht. Alle Spalten im Bereich Variabel werden dann mit in den Spaltenmanager gezogen.


Fusszeile

Fusszeile

In der Fusszeile der Tabelle wird in der ersten Spalte immer die Anzahl der Datensätze dieser (Tabelle) bzw. Entität der Adisdatei angegeben.

Daneben werden (wenn die Spalte so konfiguriert ist ) die Durchschnitte angezeigt.

Wie Sie oben in der Graphik sehen, haben Sie noch weitere selbsterklärnde Möglichkeiten die Tabelle nach Ihren Wünschen auszugestalten.

Sortierung siehe auch hier


Gruppieren

Gruppieren

Wenn man den Haken in Gruppieren setzt (unten im Fenster), erscheint oberhalb des Tabellenkopfes ein blaues Band .

In dieses Feld können Spalten gezogen werden um Sie zu gruppieren, d. h. gleiche Werte der betreffenden

Spalte werden zusammengefasst.

Die Spalte, die in das Gruppierenfeld gezogen wurde, findet sich automatisch im

Spaltenmanager wieder und kann bei Bedarf in die Tabelle gezogen werden.

Die Knoten (+ oder -) können mit "Knoten expandieren" oder "Knoten implodieren"

mit einem Tastendruck kptl. geöffnet oder geschlossen werden.


Sortierung

Sortierung

Die Sortierung der Spalten erfolgt durch einen Klick auf den Spaltennamen. Der kleine graue Pfeil zeigt dann an, ob

Aufwärts oder Abwärts sortiert wird. Durch festhalten der "Groß-Taste" oder "Shift-Taste" und Klick mit der linken Maus-

taste auf den Spaltennamen sind Mehrfachsortierungen möglich.

siehe auch hier .


Spaltenwerte ändern

Spaltenwerte ändern

.Mit Click auf "Spaltenwerte ändern " erscheint folgendes Fenster:

Unter "Spalte auswählen" erhalten sie in einer Liste alle verfügbaren Spalten der aktuellen Tabelle. Das "VN" vor der sechsstelligen Zahl können Sie ignorieren. Unter "Spalteninhalt wird ersetzt mit:" tragen Sie den Wert ein.

Dabei sollten Sie folgendes beachten:

- ist kein Filter gesetzt werden alle Werte dieser Spalte nach einer Sicherheitsabfrage ersetzt.

Wie Datensätze innerhalb einer Tabelle gefiltert werden erfahren sie hier

- ändern Sie nach Möglichkeit nicht gerade die Spalte auf der der Filter liegt. Nach der Ersetzung verschwinden die

die Datensätze, weil Sie dann der Flterbedingung nicht mehr entsprechen. Wenn Sie dann den Filter aufheben sind alle Datensätze

wieder da

- beachten sie die Anzahl der Zeichen die eingetragen werden dürfen. Was drüber ist, wird abgechnitten!

In der Linken Tabelle unter der Spalte "Länge-Komma Stellen "erhalten Sie mehr Informationen

- [image] Ist der zu ersetzende Wert ein Listenfeld, so schauen Sie erst nach, was dort rein darf

hier z.B. darf nur eine Zahl zwischen 0-4 rein

- ist die zu ändernden Spalte ein Datumsfeld dann z.B nur TT.MM.YYYY, sonst erhalten Sie eine Fehlermeldung.

- ist die zu ändernden Spalte ein Zeitfeld dann z.B nur hh:mm:ss, sonst erhalten sie eine Fehlermeldung.

- ist die Spalte als Integer (ganze Zahl) formatiert sind nur ganze Zahlen zulässig

- Spalten mit Kommastellen "03,1" (heißt maximal 3 Zahlen und eine Kommastelle) dürfen nur mit Punkt, welcher das Komma ersetzt, eingetragen werden. Es darf in diesem Falle also nur folgendes eingetragen werden: 12.2 oder 1.2 oder 1.

Nicht 12,2 ; 222 oder 333.34. Es ist die Anzahl der Zahlen und der Punkt als Komma an der richtigen Stelle entscheidend.

Alles über Aufbau und Struktur von Adisdateien erhalten sie hier:Vit-Adis unter Adis Info


Filtern

Filtern

Eine weitere Filterung von Datensätzen ist auch hier möglich, in dem man den schwarzen Pfeil rechts neben dem Spaltennamen drückt;

diesen erhält man durch Drücken auf Tabellenfilter

(Alle) heißt alle Werte der Spalte werden angezeigt.

Kicken Sie einen speziellen Wert an, werden nur die Zeilen der Spalte angezeigt die diesem Wert entsprechen.

Der schwarze Pfeil links neben dem Spaltennamen wird bei einer Filterung zur besseren Erkennung blau gefärbt.

(Benutzerdefiniert...) es wird ein Fenster geöffnet:

In dem linken Feld wird die Bedingung aus einem Listenfeld eingetragen:

In dem rechten Listenfeld muss ein entsprechender Wert eingetragen oder wenn es ein Listenfeld ist, ein entsprechender

Wert ausgewählt werden. Die beiden unteren Spalten sind so wie oben zu handhaben(optional) und werden mit einer

"Und-Oder-Bedingung" verknüpft. mit "Ok" wird gespeichert.

Zu 1 Durch Klicken auf das schwarze Kreuz wird die komplette Spezialfilterung der Tabelle aufgehoben. Einzelne Teile

der Filterung durch drücken auf "(Alle)" des speziellen Feldes.

Zu 2 Click auf "Anpassen" öffnet folgendes Fenster:

hier kann man die filterbedingung nochmals genauer spezifizieren - bei Bedarf speichern oder

wieder laden


Eigenschaften Tabelle

Eigenschaften Tabelle

In diesem Fenster können Sie die Spalteneigenschaften jeder einzelne Spalte der gewählten Tabelle/Entität ändern.

Unter Spaltenauswahl wählen Sie die Spalte aus die Sie deren Eigenschaften Sie ändern wollen.

Unter Spaltennahme können Sie einen passenden Namen auswählen bzw. ändern.

Ist der Wert für Kommastelle <>0 (1-4) können Sie nur den Spaltennamen ändern.

Ist der Datentyp "Date","Integer" oder "Time" können Sie Codeset und Memoryfeld nicht ändern.

Ist Codeset leer können Sie das Memoryfeld nicht ändern.

Existiert noch kein Eintrag in der Datenbank können Sie diesen anlegen.

Wird Datentyp oder Codeset geändert , so muß die Adis-Datei noch mal neu geladen werden damit

die Änderung wirksam wird.


Spaltenmanager

Spaltenmanager

Durch wählen im Menue "Spaltenmanager" erscheint in der rechten unteren Ecke der Tabelle ein neues Fenster.

Jede Tabelle (Entität der Adisdatei) hat einen eigenen Spaltenmanager. Er ist ein Container für nicht benötigte Bänder (Bereiche) oder

Spalten der Tabelle . Siehe auch hier.


CSV/Text / Html / XML

CSV/Text / Html / XML

Die aktuelle Tabelle können Sie hiermit in oben genannte Formate abspeichern.

Für das Abspeichern als CSV Datei wählen Sie "Text" mit folgenden Optionen:

als Separator muss ";" stehen. AnfangZeichen und EndZeichen muss leer sein.

zu "alles expandieren" und "alles speichern" siehe hier


Exel

Exel

Die aktuelle Tabelle wird hier als Excel-Datei abgespeichert.

Dabei ist folgendes zu beachten:

zu Pkt. 1 wenn gewählt werden beim Abspeichern in Exel alle Knoten expandiert

zu Pkt. 2 wenn gewählt werden alle Datensätze der Tabelle in der Exel-Datei gespeichert-

sonst nur die selektierten Datensätze (selektieren wie im Explorer mit Strg-Taste

oder Shift oder HochTaste)

Tip: wenn Sie die selektierten Datensätze mit Strg+c-Taste in die Zwischenablage

kopieren können Sie die Datensätze z.B. in Exel oder Word einfügen.


AdisStruktur

AdisStruktur

In diesem Fenster haben Sie die Möglichkeit die Struktur ihrer AdisDatei anzusehen.


Drucken

Drucken

Hier haben sie vielseitige Möglichkeiten das Aussehen Ihres Druckes zu gestalten.

Besonders sieh unter "Datei" -Design und Seite einrichten.